This is the documentation for CDH 5.1.x.
Documentation for other versions is available at Cloudera Documentation.

Llama Incompatible Changes

The following changes have made in the Llama API to help solve synchronization problems:
  • As of CDH 5.1, the Reserve API requires you to provide the reservationId as part of the request. In previous releases, the reservationId was auto-generated and returned to the user.

    The TLlamaAMReservationRequest has an additional field called reservation_id which needs to be initialized to a UUID value. If you do not set this field, the request will result in an error with the error code set to ErrorCode.RESERVATION_NO_ID_PROVIDED.

  • The Expand API now requires you to provide the expansionId as part of the request. In previous releases, the expansionId was auto-generated and returned to the user.

    The TLlamaAMReservationExpansionRequest has an additional field called expansion_id which needs to be initialized to a UUID value. If you do not set this field, the request will result in an error with the error code set to ErrorCode.EXPANSION_NO_EXPANSION_ID_PROVIDED