This is the documentation for Cloudera 5.4.x. Documentation for other versions is available at Cloudera Documentation.

Sqoop 1 Prerequisites

  • An operating system supported by CDH 5
  • Oracle JDK
  • Services which you wish to use with Sqoop, such as HBase, Hive HCatalog, and Accumulo. Sqoop checks for these services when you run it, and finds services which are installed and configured. It logs warnings for services it does not find. These warnings, shown below, are harmless.
    > Warning: /usr/lib/sqoop/../hbase does not exist! HBase imports will fail.
    > Please set $HBASE_HOME to the root of your HBase installation.
    > Warning: /usr/lib/sqoop/../hive-hcatalog does not exist! HCatalog jobs will fail.
    > Please set $HCAT_HOME to the root of your HCatalog installation.
    > Warning: /usr/lib/sqoop/../accumulo does not exist! Accumulo imports will fail.
    > Please set $ACCUMULO_HOME to the root of your Accumulo installation. 
Page generated August 17, 2015.