CDH 4.1.3

Cloudera’s 100% Open Source Hadoop Platform

What's New in CDH4.1.3


This is a maintenance release that fixes a number of issues including the following:

  • HADOOP-6762 - Exception while doing RPC I/O closes channel

  • HBASE-6927 - WrongFS using HRegionInfo.getTableDesc() and different fs for hbase.root and fs.defaultFS

  • HBASE-7336 - HFileBlock.readAtOffset does not work well with multiple threads

  • HBASE-7498 - Make REST server thread pool size configurable

  • MAPREDUCE-2217 - The expire launching task should cover the UNASSIGNED task

  • MAPREDUCE-4765 - Restarting the JobTracker programmatically can cause DelegationTokenRenewal to throw an exception

  • MAPREDUCE-4907 - TrackerDistributedCacheManager issues too many getFileStatus calls

  • OOZIE-809 - MySQL TEXT columns should be MEDIUMTEXT

  • OOZIE-994 - ActionCheckXCommand does not handle failures properly

  • OOZIE-1051 - Repeating errors for workflows that were already killed

  • OOZIE-1130 - Upgrade from 3.2 to 3.3 failing due to change in WorkflowInstance structure

  • PIG-2966 - Test failures on CentOS 6 because MALLOC_ARENA_MAX is not set

  • SQOOP-721 - Duplicating rows on export when exporting from compressed files.

  • FLUME-1762 - File Channel should recover automatically if the checkpoint is incomplete or bad by deleting the contents of the checkpoint directory.

  • FLUME-1820 - Should not be possible for RPC client to block indefinitely on close().

CDH4.1.3 Documentation

The following guides describe how to install, configure, and secure CDH4.

  • CDH4.1.3 Release Notes
  • CDH4 Requirements and Supported Versions
  • CDH4 Quick Start Guide
  • CDH4 Installation Guide
  • CDH4 High Availability Guide
  • CDH4 Security Guide
  • Hue 2 User Guide

CDH 4.x Requirements and Supported Versions

Supported Operating Systems

CDH4 provides packages for Red-Hat-compatible, SLES, Ubuntu, and Debian systems as described below.

Operating System

Version

Packages

Red Hat compatible



Red Hat Enterprise Linux (RHEL)

5.7

64-bit


6.2

64-bit, 32-bit

6.4

64-bit

CentOS

5.7

64-bit


6.2

64-bit, 32-bit


6.4

64-bit

Oracle Linux with Unbreakable Enterprise Kernel

5.6

64-bit

6.4

64-bit

SLES



SLES Linux Enterprise Server (SLES)

11 with Service Pack 1 or later

64-bit

Ubuntu/Debian



Ubuntu

Lucid (10.04) - Long-Term Support (LTS)

64-bit


Precise (12.04) - Long-Term Support (LTS)

64-bit

Debian

Squeeze (6.0.3)

64-bit

  Note:
  • For production environments, 64-bit packages are recommended. Except as noted above, CDH4 provides only 64-bit packages.
  • Cloudera has received reports that our RPMs work well on Fedora, but we have not tested this.
  • If you are using an operating system that is not supported by Cloudera's packages, you can also download source tarballs from Downloads.

Supported Databases

Supported JDK versions

Supported Internet Protocol