Upgrading from an Earlier CDH 5 Release to the Latest Release

Important Tasks

  • Upgrading from any release earlier than CDH 5.4.0 to CDH 5.4.0 or later requires an HDFS metadata upgrade.
  • Upgrading from a release earlier than 5.2.0 requires all of the following:
    • Upgrade HDFS metadata
    • Upgrade the Sentry database
    • Upgrade the Hive database
    • Upgrade the Sqoop 2 database
Make sure you also do the following tasks that are required for every upgrade:
  • Upgrade the Oozie database and shared library
  • If you have uploaded the Spark assembly JAR file to HDFS, upload the new version of the file

Each of these tasks is described in context as you proceed through the upgrade. The following sections provide the information and instructions you need: