Package Dependencies (version 5.12)

When upgrading Cloudera Manager note that the following packages may be installed or upgraded as part of the steps taken by the upgrade wizard.

RHEL/CentOS
  • bind-utils
  • chkconfig
  • cyrus-sasl-gssapi
  • cyrus-sasl-plain
  • fuse
  • fuse-libs
  • gcc
  • httpd
  • init-functions
  • libxslt
  • mod_ssl
  • MySQL-python
  • openssl
  • openssl-devel
  • openssl-devel
  • perl
  • portmap
  • postgresql-server >= 8.4
  • psmisc
  • python >= 2.4.3-43
  • python-devel >= 2.4.3-43
  • python-psycopg2
  • python-setuptools
  • sed
  • service
  • sqlite
  • swig
  • useradd
  • zlib
SLES
  • apache2
  • bind-utils
  • chkconfig
  • cyrus-sasl-gssapi
  • cyrus-sasl-plain
  • fuse
  • gcc
  • libfuse2
  • libxslt
  • openssl
  • openssl-devel
  • perl
  • portmap
  • postgresql-server >= 8.4
  • psmisc
  • python >= 2.4.3-43
  • python-devel >= 2.4.3-43
  • python-mysql
  • python-setuptools
  • python-xml
  • sed
  • service
  • sqlite
  • swig
  • useradd
  • zlib
Debian/Ubuntu
  • ant
  • apache2
  • bash
  • chkconfig
  • debhelper (>= 7)
  • fuse-utils | fuse
  • gcc
  • libfuse2
  • libsasl2-modules
  • libsasl2-modules-gssapi-mit
  • libsqlite3-0
  • libssl-dev
  • libxslt1.1
  • lsb-base
  • make
  • openssl
  • perl
  • postgresql-client@@PG_PKG_VERSION@@
  • postgresql@@PG_PKG_VERSION@@
  • psmisc
  • python-dev (>=2.4)
  • python-mysqldb
  • python-psycopg2
  • python-setuptools
  • rpcbind
  • sed
  • swig
  • useradd
  • zlib1g